Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthorab1sh3k
     
    Hi folks,

    I am trying to install Akelos latest version in Xampp latest version. and I get the following deprecated method errors,

    Deprecated: Assigning the return value of new by reference is deprecated in D:\xampp\htdocs\project\app\controllers\framework_setup_controller.php on line 229

    Stacktrace (most recent call first):
    File: D:\Akelos1.0.1\lib\AkActionController\AkCacheHandler.php
    line: 809
    code:
    <? header('Content-Encoding: '.($xgzip?'x-gzip':'gzip'));

    params:
    (string): Content-Encoding: gzip


    File: D:\Akelos1.0.1\lib\AkActionController.php
    line: 2043
    Variable function called: beforeNoCache
    code:
    <? $filter_result = $filter[0]->$filter[1]($this);

    params:
    (object): FrameworkSetupController


    File: D:\Akelos1.0.1\lib\AkActionController.php
    line: 2023
    code:
    <? return $this->_callFilters($this->_beforeFilters, $method);

    params:
    (array): => (
    (array): => (
    (object): AkCacheHandler
    (string): beforeNoCache
    )
    (string): initFrameworkSetup
    )
    (string): index


    File: D:\Akelos1.0.1\lib\AkActionController.php
    line: 2000
    code:
    <? if ($this->beforeAction($method) !== false && !$this->_hasPerformed()){

    params:
    (string): index


    File: D:\Akelos1.0.1\lib\AkActionController.php
    line: 207
    code:
    <? $this->performActionWithFilters($this->_action_name);

    params:
    (string): index


    File: D:\Akelos1.0.1\lib\AkDispatcher.php
    line: 47
    code:
    <? $this->Controller->process($this->Request, $this->Response);

    params:
    (object): AkRequest
    (object): AkResponse


    File: D:\xampp\htdocs\demographics\app\controllers\framework_setup_controller.php
    line: 230
    code:
    <? $Dispatcher->dispatch();


    File: D:\xampp\htdocs\demographics\public\index.php
    line: 26
    Variable function called: require
    code:
    <? 'app'.DIRECTORY_SEPARATOR.'controllers'.DIRECTORY_SEPARATOR.'framework_setup_controller.php');

    params:
    (string): D:\xampp\htdocs\demographics\app\controllers\framework_setup_controller.php


    File: D:\xampp\htdocs\demographics\index.php
    line: 19
    code:
    <? include('public'.DIRECTORY_SEPARATOR.'index.php');

    params:
    (string): D:\xampp\htdocs\demographics\public\index.php


    Controllers

    \app\controllers\framework_setup_controller.php
    Models

    \app\models\framework_setup.php

    I learned from the forums that I have to set up E_ALL to E_ALL & ~E_DEPRECATED. I tried doing in framework_setup_controller.php. And it did not change anything. I could not find other accurances as I am using it in windows machine and doing a search did not work well.

    Any other suggestions are welcome.

    Thanks,
    Abhi
    • CommentAuthorpogeybait4883
     

    This is just a suggestion but try editing your php.ini and set the following option to 'On':

    allow_call_time_pass_reference = On