Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthorfrantzdae
     
    I'm trying to install Akelos for the first time. After setting up the database.yml file, Akelos works, but I get 4 errors:

    (Unknown error (8192)) Assigning the return value of new by reference is deprecated
    (Unknown error (8192)) Function split() is deprecated
    (Warning) Cannot modify header information - headers already sent by (output started at /home/frantzdae/akelos_framework/lib/AkActionController/AkCacheHandler.php:740)
    (Notice) ob_end_flush() [ref.outcontrol]: failed to delete and flush buffer. No buffer to delete or flush.

    I googled for a while, and found some informations about PHP's E_DEPRECATED, so I tried to write this line in config.php:
    define("AK_ERROR_REPORTING", E_ALL ^ E_DEPRECATED);
    but I got the following error: Content Encoding Error, The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

    What should I do?
    I'm using Linux (Ubuntu) + Xampp. My PHP's version is 5.3.

    (sorry for my bad english)
    • CommentAuthorpogeybait4883
     
    Try editing your /etc/php.ini file and change the error_reporting in there. I use "error_reporting = E_ALL & ~E_NOTICE" . You'll need to start php afterwards. See if that helps.
    • CommentAuthorfrantzdae
     
    I've changed the error_reporting in php.ini, from development (E_ALL | E_STRICT) to production (E_ALL & ~E_DEPRECATED) and now everything works fine. Thanks pogeybait for your help!
    •  
      CommentAuthorBedfordWriter
     
    Hi,
    I didn't get the same result. Setting an error level in code takes priority over whatever was in the php.ini file.

    Taking a brute force approach, I solved the problem by doing the following: Everywhere that Akelos set the error reporting level to E_ALL, I calculated my own error level like so: $MY_ERROR = E_ALL & ~E_DEPRECATED; and used that instead.