Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthornselikoff
     
    Hello,

    I'm very interested in Akelos as a possible PHP framework for my next project, but I'm having a heck of a time getting past the first few steps in the booklink tutorial.

    I'm on a Mac, OS X Leopard, with Apache, PHP 5.2.6, and MySQL (I'm not using MAMP).

    I used svn to checkout Akelos, verified that Akelos could find php, and ran the setup script to create the booklink directory and symbolic link. I had to add FollowSymLinks to my /etc/apache2/users/user.conf file because I was getting a 403 error initially. I created the databases and granted the proper permissions.

    When I point my browser to http://localhost/booklink, I see a bunch of errors, backtraces, and warnings.

    The first one is this:
    (User Error) Could not load inflector rules file: config/inflector.yml

    Then a bunch of warnings:
    Warning: Call-time pass-by-reference has been deprecated in /Volumes/Data/Websites/akelos/lib/AkActionView/AkHelperLoader.php on line 74
    Warning: Call-time pass-by-reference has been deprecated in /Volumes/Data/Websites/akelos/lib/AkActionView/AkHelperLoader.php on line 76
    Warning: Call-time pass-by-reference has been deprecated in /Volumes/Data/Websites/akelos/lib/AkActionView/AkHelperLoader.php on line 78
    Warning: Call-time pass-by-reference has been deprecated in /Volumes/Data/Websites/akelos/lib/AkActionView.php on line 113
    Warning: Call-time pass-by-reference has been deprecated in /Volumes/Data/Websites/akelos/lib/AkActionView.php on line 226

    Then more errors related to write permissions and locale files, which I was able to fix by running the following commands in my akelos directory (not in my booklink directory)

    sudo chown -R www .
    sudo chmod -R g+rw .

    Another thread suggested running ./script/configure -i, which I assume should be run from the booklink directory. When I run this script, after inserting the correct database name, type, user, and password, I receive the following error:
    Could not connect to the database

    I appreciate your help.

    -Nathan
    • CommentAuthorkkrzyzak
     
    Hi Nathan,
    All I can tell you, that I'm running akelos on my Mac (10.5.7) on MAMP - php 5.2.6 too, and mysql (as well as sqlite) - and I haven't got any problems - so try to install MAMP
    • CommentAuthornselikoff
     
    Hi kkrzyzak,

    Thanks for the reply. I installed and tried MAMP, but am getting the same errors as above (after starting from scratch on the booklink tutorial).

    -Nathan
    • CommentAuthornselikoff
     

    OK, after playing with it for a bit longer I got it to work.

    As described in this thread I had to create a symlink from MAMP to the "typical" location of the MySQL socket file

    sudo mkdir /var/mysql
    sudo ln -s /Applications/MAMP/tmp/mysql/mysql.sock /var/mysql/mysql.sock
    

    This was the ONLY way I could get the ./script/configure -i script to work correctly without giving me a database connection error, and I still saw the errors listed above when trying to use the "web installer".

    According to the other threads I've seen, manually changing 'localhost' to '127.0.0.1' in the config/database.yml file is also an option, though this would require foregoing the use of the configure script.

    I have a few suggestions to the developers for making this process easier for others:

    1. Either fix the web installer so that it can be used for the initial configuration without seeing any errors, or remove it and force the use of ./script/configure -i (changing the wording in the booklink tutorial and in /script/setup)
    2. Edit the configure script to ask for a socket location if the "typical" settings aren't allowing a connection to mysql. This socket location could be written into the database.yml file, as it seems from other threads that you used to be able to specify a non-standard socket in config.php, but now all of those parameters have been moved into database.yml.

    Hope this helps someone else trying to give Akelos a shot!

    -Nathan

    •  
      CommentAuthorOliver
     

    As described in this thread I had to create a symlink from MAMP to the "typical" location of the MySQL socket file

    Under Snow Leopard, I set the following symlink:

    $ sudo ln -s /Applications/MAMP/tmp/mysql/mysql.sock /usr/local/mysql-5.0.45-osx10.4-i686
    

    However, I still have the same issue as described by Nathan in the initial post.

    Anyone has another idea how I could fix this?

    •  
      CommentAuthorOliver
     

    Under Snow Leopard, I set the following symlink:

    $ sudo ln -s /Applications/MAMP/tmp/mysql/mysql.sock /usr/local/mysql-5.0.45-osx10.4-i686

    However, I still have the same issue as described by Nathan in the initial post.

    Yay, I GOT IT WORK!

    I had to set the following symlink (instead of what I did before):

    $ sudo ln -s /Applications/MAMP/tmp/mysql/mysql.sock /private/tmp/mysql.sock
    

    This seems to be the new location of the mysql.sock under Mac OS X Snow Leopard (10.6)

    •  
      CommentAuthorOliver
     

    A helpful address when dealing with MAMP's MySQL on Mac OS X:

    http://fischerlaender.net/apple-mac/mac-os-x-trouble-with-mamp-mysql