Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthorepuente
     
    I have follow the booklink tutorial, after doing the ./script/generate scaffold Book
    and ./script/generate scaffold Author; I get the error 'Not Found The requested URL /booklink/author/show was not found on this server.' when I point to http://localhost/booklink/author
    • CommentAuthorpogeybait4883
     
    If you are getting an error 404 "Not Found" then it seems Akelos isn't installed correctly. If a route wasn't set up properly Akelos would normally give an error something like "Fatal error: Could not find the file /path/controllers/author_controller.php for the controller AuthorController in /pathto/akelos/lib/AkRequest.php on line xxx". What do you see when you go to http://localhost ?
    • CommentAuthorepuente
     
    I get "It works!" at http://localhost
    • CommentAuthorepuente
     
    If I go to http://localhost/booklink/ I get :

    Bienvenido/a a bordo
    Estás utilizando el Akelos Framework!

    Comenzando a usar el Framework

    1. Inicia la linea de comandos (promt) ubicada en script/ para crear modelos (comando "generate model") y controladores (comando "generate controller")

    Para mostrar las opciones de cada generador llamalo sin opciones.
    2. Configura las rutas (config/routes.php) o edita el controlador por omisión (app/controllers/page_controller.php)
    • CommentAuthorpogeybait4883
     
    Instead of using the scaffold, trying doing the following:

    ./script/generate model Book
    ./script/generate controller Book
    ./script/generate model Author
    ./script/generate controller Author

    You must also edit your config/routes.php file and add the following lines near the top:
    $Map->connect('/book/:action/:id',array('controller'=>'book','action'=>'index','module'=>null));
    $Map->connect('/author/:action/:id',array('controller'=>'author','action'=>'index','module'=>null));

    You will also need to edit your app/controllers/book_controller.php and app/controllers/author_controller.php and make sure there is an index action in there for both controllers. It can be as simple as this:

    function index() {}

    Next in your /app/views folder make sure there are two directories in there. One for book and one for author. Inside each directory make sure there is an index.tpl file. That takes care of your views for now.

    In the routes.php file I pointed the default action to index but the route should be able to handle any actions you create in either the book or author controller. Hope this works for you!

    -- Pogeybait
    • CommentAuthorhaakon
     
    Seems for me that you have installed akelos in the /booklink/ folder, right?
    Since / gave you "it works!" which is standard page in debian/ubuntu when you install apache.

    This means that you should probably enable mod_rewrite in apache. And you should configure akelos to know that it is residing inside /booklink/ and not /

    --
    Håkon