Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthordelia
     
    hi,
    this framework is driving me crazy! i've just installed my application in the production server, and the url_helper is generating the following paths in the views associated with the controller named "home_controller":
    <link href="/home/images/favicon.ico" rel="icon" type="image/x-icon" />
    <link href="/home/stylesheets/style.css" media="all" rel="Stylesheet" type="text/css" />

    It only happens with that controller and in the production environment. Why could it be? Why the helpers appends the word "home" at the path. Please Help!
    • CommentAuthorpannet1
     
    hello,

    just a guess. could be that you used the word home in your path somewhere during your development and same is now there in your production server.

    best regards
    • CommentAuthordelia
     
    thanks for your answer pannet1. but that is not the problem. i suppose is something with the apache document root (that is /home/d348716/public_html), but i dont know how to solve it. i think i am going to rename the home_controller, and forget about the problem....
    •  
      CommentAuthorbermi
     

    Hi Delia,

    Akelos tries to wire your application paths with the resolving URL's

    these two constants are set automagically by akelos

    AK_SITE_URL_SUFFIX
    AK_ASSET_URL_PREFIX
    

    so you don't have to.

    It can be that with you current file layout Akelos is not guessing correctly these values.

    If you define these constants on your config.php file, it will prevent Akelos from setting it automatically.

    Could you please report on the paths you used on your local box and on the production server (both /base/url/path and /base/file/path).