Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthorstarchy
     
    Hello, I'm trying to install Akelos from the browser but I'm getting the following error:

    User Error: Could not load inflector rules file: config\inflector.yml in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\akelos\lib\AkInflector.php on line 56

    and then there's a bunch of backtrace stuff. Not sure what I should do after this point. I've already enabled rewrite engine, pear, and allow_call_time_pass_reference which removed a lot of other errors but now I'm stuck. o.O

    Also, I don't think I have command line access on my shared webhost. Would it be possible to create projects and upload those & Akelos to my host and get it to run properly without command line installation?

    Thanks for the help!
    • CommentAuthorbenny
     
    you should try running ./script/configure -i
    in your local, when you have it ready the import them into the server, project files (first remove tmp/cache files) and sql scripts.

    Or try older akelos framework from revision 1247
    • CommentAuthorstarchy
     
    Hello, thanks for your help. I think Akelos is a bit too advanced for me right now so I'm looking at something simpler to learn. Maybe one day I will figure out how to do this.
    • CommentAuthorfcedillo
     
    @benny: what do you refer to with "sql scripts"
    • CommentAuthorrobw00t
     
    fyi this resolved the issue for me. I downloaded a fresh copy of Akelos via SVN and installed in under a fresh install of the XAMPP stack. Upon visiting the index page (after enabling AllowOverride in apache httpd.conf) I encountered the same error. I then ran this command:

    E:\Documents and Settings\Rob\My Documents\xampp\htdocs\akelos\script>"E:\Documents and Settings\Rob\My Documents\xampp\php\php" configure
    Your application has been confirured correctly
    See config/config.php and config/database.yml
    E:\Documents and Settings\Rob\My Documents\xampp\htdocs\akelos\script>

    And wala, now the Akelos homepage is coming up correctly for me. Thanks for the help!
    • CommentAuthoromegasharp
     
    I experienced the same problem, running "script/configure -i" did not solve the problem.
    Indeed, the only difference the "configure -i" did is:
    1) config/database.yml
    2) config/config.php:
    defined('AK_FRAMEWORK_DIR') ? null : define('AK_FRAMEWORK_DIR', 'C:\\akelos');
    Change the path ...
    3) app/controllers/framework_setup_controller.php:
    defined('AK_FRAMEWORK_DIR') ? null : define('AK_FRAMEWORK_DIR', 'C:\\akelos');

    After this, I still experience problems. So I did the reverse, generate the application in Unix, then port back to Windows. This time my apache server (Xampp) stopped responding in Windows Vista ...

    Finally I found that the trick is to remove /config/cache directory, remove all compiled/ directory under views, and maybe also clear contents inside /tmp directory. Viola!