Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthoralperthereal
     
    hey, this is something i ran into yesterday. it took me some time to find the root cause -- i wanted to share it with the devs in case they want to fix it (or not).

    i usually don't do this but it was one of those days and the folder i created for my application had a space in it (my application instead of myApplication or my_application). while i was trying to install the admin plugin i was seeing outputs like:

    Installing plugin.
    Done.

    Nothing else. Looking at the AkPluginManager.php code, i see that svn is executed however its output is not redirected to the command line. my first suggestion would be to redirect all the output (at least errors?) from external command executions. then, of course, i realized that the problem was with svn command -- it was unable to parse the arguments passed since of them had a space in it. i surrounded $plugin_dir with quotes and it worked fine -- which is my second suggestion: surrounding directories with quotes if they are used as an external program argument.