Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthorreyntjensw
     
    Hi,

    Could you tell me how I Can easily deploy Akelos to my webserver? I did try to upload the framework folder and the app folder, but that didn't work:s( I did change the dir of the framework dir!)

    Thanks
    •  
      CommentAuthorphilippgerard
     

    Did you edit the configuration files so that they fit to the new enviroment? Did you create all required databases as well as the appropriate tables?

    • CommentAuthorreyntjensw
     
    I did edit the config file, but it didn't help. The db's are created and the connection is working.
    • CommentAuthorinsanet
     

    you need to specify more, what exactly didnt work? what is showed in the main page?.

    • CommentAuthorreyntjensw
     
    So i created this testapp http://chismoor.net/akelos/online/
    The db exists and the settings to the basefolder (permission 755) are fine.

    On my developmentmachine everything works fine. What info do you need more?

    The server is running centos with directadmin installed.

    Thanks in advance
    • CommentAuthoralake
     

    I have good news and I have bad news. The good news is that I have a Wiki entry that describes the process that I've followed. The bad news is that my deployment doesn't work either.

    When I try to run the project (with and without admin), I get a blank screen. I'd be happier if I could get an error message (at least). I recall someone talking about PHP memory on the remote host, but I don't know how to determine if I have this problem.

    So, I'll be watching this forum...

    • CommentAuthorreyntjensw
     
    I hope that someone can fix this problem because I really like to use akelos!
    • CommentAuthoralake
     

    My Akelos software runs fine on my local server. The setup that I had on my previous post was to have Akelos and my project in my remote host;s public_html directory. This would be no good in a production environment, but it was OK for testing. However, as I noted, it wouldn't run.

    I've uploaded Akelos and my project to my remote server again, but this time into my private_html subdirectory. On my remote host, I can't create symlinks. I got the host manager to create the symlink from public_html to private_html/project/public/. After he did so, the link properties said it was broken, even though it pointed to a valid location. He worked with it but said that Apache caused segfaults in the system when he tried to use it. He's advised me to find another way to give Apache access to my private_html/project/public directory.

    Is there some way that one could have a public_html/project/public directory with the current contents and an additional config file that would carry a pointer to the private_html/project directory so that a symlink wouldn't be necessary? Of course, private_html/project/config/config.php would have to point to the public directory, too. And some references would have to be changed, but would this work?

    One of the attractive things about Akelos is the fact that it is a PHP product. To me, this means that it should run on any server that has a current version of PHP on it. If this isn't so, I'll have to find another web hosting service. But if I have to do this, I'd like to know what Akelos requires so that I can make inquiry before I contract with the company. Even so, if I write for others using Akelos, I may not have control over what web hosting service they might want to use.

    My remote installation of Akelos and my project are in a subdomain. Could this be the problem?

    • CommentAuthoralake
     

    My hosting service tells me that the machine is a virtual host and that the problem is the interface between Apache and Akelos. He advises me to look for another service. Has anyone else had this problem? Is there a fix for it?

    • CommentAuthoralexpophal
     
    I solved this problem editing the files /config/cache/{environment}/caching.php and /config/cache/{environment}/sessions.php to match my remote's environment path. Tell us if this solve your problem.