Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthorgranchard
     
    Hello list,

    I am very new to Akelos. I am using a shared vps host and
    continue to get the following error in putty when executing ./script/setup -h
    bad interpreter: permission denied
    I have exhausted google looking for others experiencing this error. But nada.
    Any suggestions greatly appreciated.

    Grant
    • CommentAuthorKaste
     

    that's most probably a linux-configuration problem. Akelos should give you a nicer error-message.

    bad interpreter ?

    • CommentAuthormokelly1
     
    I am having the same issue. When I try to bring up akelos in a browser I get the following message

    Access forbidden!

    You don't have permission to access the requested directory

    My permissions are set to 777 for all akelos files. The owner and group for all files is www user and group wwwrun, the same as my linux apache server.

    I would like to have a look at akelos but cannot get it to work. I have not found any configuration or installation information. There is plenty of information about starting a project but nothing about installing akelos.
    • CommentAuthordemaio
     

    i've checked akelos on Debian Etch, Ubuntu Hardy, FreeBSD and CentOS recently. Everything has worked as expected , so I think that' s is not an issue related to OSes... By the way ,if other PHP apps work on your box , Akelos should too

    It is enough to make sure that apache has w and x access to the cache, locales and tmp dirs As to instalation script, it is fairly easy to write one using rake. I would provide mine but it is too tightly coupled with the layout of my project dirs, it changes some predefined Akelos app constants as well ...

    Sometimes .htaccess files , which are placed in some dirs above akelos public dir cause unexpected behaviour , so I recommend paying attention to them ...

    There are a lot of predefined constants in lib/constants.php file in Akelos framework lib dir ... It is good to get acquainted with them. In majority of cases their names are selfexplanatory ...

    best regards Demaio

    • CommentAuthormokelly1
     
    I was finally able to get beyond the permissions problem and now I have a screen ful of:

    Warning: Call-time pass-by-reference has been deprecated; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file in /srv/www/htdocs/rockwallcomputer/akelos/lib/AkActionController.php on line 1689

    I changed my PHP.ini file allow_call_time_pass_reference setting to true and later to on and could not get rid of the above message.
    • CommentAuthormokelly1
     
    The way I was able to get beyond the permissions problem was by deleting .htaccess. Perhaps this is why I get the warning message. I see your recommendation to pay attention to .htaccess files in the tree above akelos but I do not know what this means.

    There are no .htaccess files in the parent directory of akelos which is the webroot.

    I reloaded the .htaccess file and uncommented the Options +FollowSymLinks line and was able to access Akelos. Still have the warning message about pass by reference.

    I added the following to .htaccess to stop the warning messages but it did not work. I suppose the script is resetting these values to something else.
    php_flag display_errors off
    php_value error_reporting 0

    I am able to get through some of the configuration but when I click submit on the page Please set your database details, I get a couple of pages of Warning: Call-time pass-by-reference messages and then two :
    Warning: Cannot modify header information - headers already sent by (output started at /srv/www/htdocs/rockwallcomputer/akelos/lib/AkActionController.php:1702) in /srv/www/htdocs/rockwallcomputer/akelos/lib/AkResponse.php on line 109

    Thanks for your help.
    Mo