Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthorprtscr
     

    I got a slight problem:

    Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of  
    [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However,  
    future versions may not support this any longer. in C:\Alfred\Webb\Server\akelos_framework\lib\AkActionController.php on line 214
    

    This error repeats about 20-30 times with different code lines. Anyone know how I can solve this? My webserver is setup @ c:\alfred\webb\server and the application resides in c:\alfred\webb\server too

    Thanks in advance!

    • CommentAuthorjereme
     
    You should be able to find a pass-by-reference directive in your php.ini file that you can enable. If you do that, then restart the web server, you should be good to go.
    • CommentAuthorjereme
     
    More specifically you are looking for a line that says:

    allow_call_time_pass_reference = Off

    You need to set it to on. Your php.ini is probably in C:\WINDOWS or C:\PHP.
    • CommentAuthorprtscr
     
    Thanks a lot for the fast and accurate answer! ;)
    • CommentAuthormilinmestry
     
    Hi jereme,
    I had facing the similar problem while creating module Book and Author.
    -------------------
    command on bash:
    ------------------------
    abc@debian:~/booklink$ ./script/generate scaffold Book

    Fatal error: Only variables can be passed by reference in /var/www/abc/akelos/akelos_framework/lib/utils/generators/AkelosGenerator.php on line 253

    I have chekced the "allow_call_time_pass_reference = On" which is on, in php.ini file.

    what could be the solution for this error?
    • CommentAuthorOmeZ
     
    which version of framework you use now?
    •  
      CommentAuthorbermi
     

    @milinmestry Make sure your php command uses the same php.ini as your web server php.ini, sometimes there might be different php installations on your machine.

    You can check it out with

    php -i | grep reference