Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    •  
      CommentAuthoramir
     
    hi
    I have e problem with links in akelos
    I have my application in myapp folder in webroot so I have access to it
    on this address http://localhost/myapp/
    in the main page of website the links that have been generated by link_to are not clean
    for example <%= link_to _('Products'), :controller => 'products', :action => 'index' %> generates
    http://localhost/myapp/?ak=/products/
    but when I open the main page with this address http://localhost/myapp/en/ everything will be ok
    and link_to generates a path like this http://localhost/myapp/en/products/
    where is the problem?
    thanks
    • CommentAuthorasejua
     

    You can try opening the .htaccess file inside your app directory and check if the RewriteBase directive line is commented out (it is by default and, unless the app directory is under an alias, it should be commented)

    You could also check the routes.php file for any map pointing to an 'amircms' folder over there.

    Hope it helps :)

    •  
      CommentAuthoramir
     
    Excuse me I the amircms in the last post was wrong I've edit it now.
    I've checked the .htaccess file the RewriteBase directive line is commented out.
    I've checked routes.php too. There is nothing wrong with that.
    • CommentAuthorKaste
     

    you can manually

    define(AK_URL_REWRITE_ENABLED,true)
    

    in config/config.php so Akelos doesn't try to be smart and autodetect your rewrite-settings.

    •  
      CommentAuthoramir
     
    Thank u Kaste