Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthorKriM
     
    svn co http://svn.akelos.org/trunk/ akelos
    in this step i have no errors)

    ----next step
    krim@krim-laptop:/var/www$ cd akelos/
    krim@krim-laptop:/var/www/akelos$ sudo ./akelos project/blog
    #!/usr/bin/env php
    Creating directory: /var/www/akelos/project/blog/project/blog
    There where some errors during the installation process:
    * Can't create directory: /var/www/akelos/project/blog

    Hmm.... error o_0. On screencast i hadn't saw this error, ok, i create dir by myself.

    -----next step
    http://pastebin.com/m64f48e43

    Omg o_0 many errors, can u help me?
    sorry for my bad english.
    • CommentAuthorpannet1
     

    Hello krim,

    comment followed by

    code

    get latest akelos framework from akelos.org website

    wget http://www.akelos.org/download

    extract the archive

    tar zxvf akelos_framework-dev_preview.tar.gz

    mv to your project directory

    mv akelos_framework ~/akelos

    create permission file using your favourite editor

    vi ~/sites/apache

    add this content to above said apache file

    chown apache:users . -Rv chmod g+rw . -Rv

    make it executable

    chmod +x ~/apache

    cd to directory where we moved akelos

    cd ~/akelos

    now run akelos project creating script

    that creates project and adds a softlink to your webroot

    modify to suit your need

    ./script/setup -d ~/sites/booklink -p ~/public_html/booklink

    make it usable by apache by running the script we created

    ~/sites/apache ~/sites/booklink

    now change to your project directory

    cd ~/sites/bookink

    run configure script from booklink project directory

    and answer the questions. watch out for mysql

    username and password, others are mostly default

    script/configure -i

    now point the link which you created in the webroot

    in this example

    http://localhost/booklink

    i get this error

    Fatal error: Could not create config cache dir /home/expocgo/sites/booklink/config/cache/testing in ~/akelos/lib/AkConfig.php on line 196

    Warning: file_put_contents(~/sites/booklink/config/locales/en.php) [function.file-put-contents]: failed to open stream: Permission denied in ~/akelos/lib/Ak.php on line 358

    will get back to you soon

    regards

    • CommentAuthorpannet1
     

    hello krim,

    i rectifed the permission problem

    substitute your login name

    chown <login name>.www-data ~/sites/booklink -Rv

    next add the following to app/installer/booklink_installer.php

    located in your project booklink directory

    <?php

    class BooklinkInstaller extends AkInstaller { function up_1(){

         $this->createTable('books',
            'id,'.          // the key
            'title,'.       // the title of the book
            'description,'. // a description of the book
            'author_id,'.   // the author id. This is how Akelos will know how to link
            'published_on'  // the publication date
        );
    
         $this->createTable('authors', 
            'id,'.      // the key
            'name'      // the name of the author
            );
     }
    
     function down_1(){
         $this->dropTables('books','authors');
     }
    

    }

    ?>

    run the migrate script for the project

    which will actually populate the tables

    with the columns

    ./script/migrate Booklink install

    errors noticed but did not stop the script

    from running

    Warning: touch(): Utime failed: Operation not permitted in ~/akelos/lib/AkConfig.php on line 159 1146: Table 'booklink_dev.authors' doesn't exist

    try running the scaffold script as mentioned in the

    booklink tutorial

    ./script/generate scaffold Author

    again same error

    Warning: touch(): Utime failed: Operation not permitted in ~/akelos/lib/AkConfig.php on line 159

    now pointing the below link to the browser should work

    http://localhost/booklink/author

    but it does not work for me

    404 Not Found

    The requested URL /booklink/author was not found on this server. Apache/2.2.11 (Ubuntu) PHP/5.2.6-3ubuntu4.1 with Suhosin-Patch Server at localhost Port 80

    Can anywell help me out please. Thanks.

    Best Regards

    • CommentAuthorpannet1
     

    hi,

    i just go the booklink work by following the below instruction

    http://i.justrealized.com/2008/12/23/how-to-enable-apache-mod-rewrite-in-ubuntu/

    ubuntu does not enable module mod rewrite by default.

    well. i did not have rewrite installed, so i first installed using

    <code> sudo apt-get install rewrite </code>

    that solved most of the problems.

    then after apache script we created earlier, i could resolve the utime() errors.

    then again, ./script/ did not create files because user www-data.users did not have permission to create files in my home folder. so i have to basically

    sudo chown <myusername>.<mygroup> . -Rv code sudo ./apache point the browser to booklink url

    do this until the development is complete

    this was very frustrating but i did this for 2 nights, without knowing how to resolve.

    finally, i resolved it today, after reading the below

    http://oneshore.wordpress.com/2009/01/28/ubuntu-www-data-user-should-be-apache/

    it basically make apache user to be <yourusername> and not www-data, which was making compelling us to use the apache script which bermi suggested.

    please note that it did not require me to change .htaccess file in my ubuntu development box. however, i may have to need to use it when i finally move it to my share linux production server.

    i just started following bermi blog video and the booklink tutorial together to understand the whole progress.