Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthorsteinitz
     
    Hello,

    I'm playing around with Akelos on Mac OS X Leopard.

    For expedience, I decided to use the the sqlite option for the booklink tutorial. I created sqlite database per the naming in the install wizard:

    booklink_dev-T8KGRSUT.sqlite
    booklink_tests-T8KGRSUT.sqlite
    booklink-T8KGRSUT.sqlite

    But when I click continue, I get

    Could not connect to booklink_tests database

    I've set the permissions of everything in sight to 777

    I searched the archives but couldn't see anyone else having this problem.

    I'm going to install MySQL as a workaround but I thought this report might interest someone.

    Best regards,

    Steve
    • CommentAuthorsteinitz
     
    Hello again,

    I installed mysql and created an akelos user. I created the three databases and granted privileges to akelos for all three. Using MySQL Administrator, I confirmed that the akelos user can access the three databases. I ran the booklink wizard at localhost/booklink and got the same message as before: Could not connect to booklink_tests database. Is there any way I can get more detailed diagnostic messages?

    I tried restarting mysql to no avail.

    Thanks,

    Steve
    • CommentAuthormvitjiten
     
    I also got the same problem as mentioned by steinitz. But then i stopped my server(apache.) and mysql. then i started again. And the problem get solved.
    Again if you r using mysql then check for password.Keep the password field blank and try once.I think you will get the solution.
    Otherwise please notice it in this blog.
    • CommentAuthorThijs
     

    Steinitz, are you using MAMP?

    If so, look here

    I had the same problem. Changing the 'socket' setting -as mentioned in the first posts- didn't work. (well, maybe now with a newer trunk version it might work)
    You'll probably have to change the socket for you system. (see the latest posts in the discussion)

    • CommentAuthorsteinitz
     
    Thank mvitjiten and Thijs.

    mvitjiten - I restarted apache and mysql and played around with password as suggested.

    Thijs - thanks for the pointer to the other thread -- I set up a symlink as suggested there.

    Its late here in Sydney. I think I'll get a fresh start tomorrow.

    Thanks again for your help.

    Steve
    • CommentAuthorsteinitz
     
    Hello,

    I had a closer look at the mamp thread. I'm not using the mamp product so I had to take a slightly different approach. A non-mamp mysql, on Mac OS X Leopard, creates the mysql.sock file at /private/tmp/mysql.sock. That file is deleted after mysql stops. Still, as an experiment based on the mamp thread, I created a mysql directory in /var and in it I created a symlink to the temporary mysql.sock file. That allowed the Akelos wizard to get to the next step.

    I think the MySQL documentation shows a way to have mysql create the socket in a less temporary location. I might look into that later.

    Thanks again for your help,

    Steve
    • CommentAuthork00k
     
    Thanks Steve. That worked for me as well. Just to clarify for anyone else in the same boat:

    1) Create /var/mysql directory
    2) Create a symbolic link to mysql.sock there with the folowing command:

    ln -s /private/tmp/mysql.sock /var/mysql/mysql.sock
    • CommentAuthorserave
     
    I'm working with wamp, and i 'be tried restarting the service of php and mysql. and it hasnot work
    server localhost user root password empty and database names booklink booklink_dev booklink_tests
    please help me
    • CommentAuthorKaste
     

    have you actually created those schemas aka "databases"? error message?

    • CommentAuthorserave
     
    Warning: Cannot modify header information - headers already sent by (output started at C:\dev\akelos\lib\AkActionController.php:1703) in C:\dev\akelos\lib\AkResponse.php on line 109

    thanks
    • CommentAuthorKaste
     

    that doesn't say nothing about database-connection. it basically says the app echoed some stuff and then tries to send headers. btw whats on line 1703 or what rev do you use.

    • CommentAuthorserave
     
    sorry for my ignorance, what do you mean by rev?
    • CommentAuthorKaste
     

    version||svn revision

    • CommentAuthorserave
     
    akelos 0.8
    just in case wamp 2.0
    • CommentAuthorKaste
     

    I actually don't know what you're trying to do. Is this somehow related to the topic of this thread?

    I would recommend you get the nightly build btw. I don't think there's a need to use 0.8 when you just start developing.

    • CommentAuthorgrowlley
     
    I had the above trouble when trying to install on wamp allso - Its complaining about call by reference.

    You need to edit your php.ini in x:\wamp\bin\php\php5.x.x and set allow_call_time_pass_reference = On. Then restart Apache.

    That should allow the wizard to complete and get you to the welcome message. Unfortunately Im stuck just passed there so I cant be of more assistance at the moment.
    •  
      CommentAuthorthisgeek
     
    Did anyone have any luck getting sqlite to work?
    •  
      CommentAuthorrobbedoes
     
    This kind of error also occurred when I was testing Django i.c.w. Sqlite.
    The solution is to change the owner of "config" to the user Apache is running as. In my case _www.
    >> cd booklink
    >> sudo chown _www config
    •  
      CommentAuthorOliver
     

    Could not connect to booklink_tests database

    For me the following workaround solved this issue (OS X 10.6 with MAMP v1.9):

    1. Connect to the database using a MySQL-GUI such as YourSQL or Sequel Pro
    2. Create the 3 databases manually (mydatabase, mydatabase_test & mydatabase_dev)
    3. Point your Webbrowser to your project's website (f.eg. http://localhost:8888/myproject/)
    4. Continue/finish the setup in the Webbrowser

    I updated the Wiki-Post for OS X accordinginly: Setting Up Akelos On Os X Snow Leopard#Hint