Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthorrmomogi
     
    I installed all for alekos, but don't open page,

    the tutorial 'book', in 'localhost/blog/' show page 'Getting started... Use script/generate to create your models and controllers ...'.
    I make this, maybe wrong with .htacess ou httpd.conf.

    I help me, please....
    • CommentAuthorsteinitz
     
    Hello,

    I'm not exactly sure from his description but I think I'm having a similar problem to rmomogi.

    In the booklink tutorial I successfully:

    - created the databases and configured Booklink to point to them (in the wizard)

    - ran script/migrate Booklink install

    - verified that the correct tables existed
    (noted that they had only been created for booklink_dev (?))

    - ran ./script/generate scaffold Book and ./script/generate scaffold Author

    - hit http://localhost/booklink/author - it gave 404 page not found

    - created .htaccess in the public web server directory and added RewriteBase /booklink
    (did I need to enable the rewrite engine?)

    - hit http://localhost/booklink/author again - it still gave 404 page not found

    rmomogi, if that is not the problem you are having, please accept my apology for hijacking your thread.

    Thanks,

    Steve
    • CommentAuthorxkenshin
     
    hey, i got the same problem..
    i'm running xampp on windows..
    after generate scaffold, i cant browse the books neither the author page..
    Can sumbody help me out..
    • CommentAuthorxkenshin
     
    hey, i managed to browse sum discussion bout dis problem..

    you can actually access the page by this URL
    http://localhost/booklink//?ak=/book
    http://localhost/booklink//?ak=/author

    Its probably sumthin wrong wif the apache configuration..
    Still wondering If there is any fixes for this..?

    thanks
    •  
      CommentAuthorbermi
     

    First of all you need to make sure mod_rewrite is enabled (if you want your app to have nice urls)

    If its enabled, you should check RewriteBase setting in your .htaccess.

    If you can see your pages using ?ak=/book/author but not /book/author, you should try changing in your .htaccess file

    # Options +FollowSymLinks
    

    with

    Options +FollowSymLinks
    

    There is a thread on server issues when using Akelos that you might find helpful.

    • CommentAuthorjujulka
     

    Probably pb in Apache config. I turned on "AllowOverride None"->"AllowOverride All", so allowed to redefine rules in .htaccess for projects

    • CommentAuthorvillocg
     
    awesome xkenshin!!!!

    That was the biggest trouble I found, now I'm keeping forward....
    • CommentAuthorhezyse
     
    Hi,
    I'm using apache for windows version 2.2 I tried all the above and I still can't access the page http://localhost/booklink/author only http://localhost/booklink//?ak=/author