Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    •  
      CommentAuthoradityamooley
     

    I have a database table 'posts' in which there's a column 'posted_on'. The installer correctly made it a date field and the scaffold is displaying date select boxes on the form.

    But when I create a new post or edit the existing one, the 'posted_on' column only gets NULL value.

    I tried with stable version as well as with latest SVN checkout but result is same in both the cases.

    Here's the table structure:

    CREATE TABLE `posts` (
    `id` int(11) NOT NULL auto_increment,
    `title` varchar(255) default NULL,
    `body` longtext,
    `posted_on` date default NULL,
    PRIMARY KEY  (`id`)
    ) ENGINE=MyISAM;
    

    Also, I noticed that the element names generated for select boxes are like post[posted_on(1i)], post[posted_on(2i)], post[posted_on(3i)]

    Am I missing something?

    •  
      CommentAuthorbermi
     

    Hi Aditya,

    I've just reproduced the bug and have opened a ticket to address this issue ASAP.

    Thanks, for reporting this. If you could post at the trac site the installer file I will add it to the test suite.

    •  
      CommentAuthoradityamooley
     

    Hi Bermi,

    Thanks for your quick response. I have added the installer file in the ticket you have opened.

    Let me know if you need more details from me.

    •  
      CommentAuthorbermi
     

    Aditya,

    By defining in your config/config.php

    define('AK_ENABLE_AKELOS_ARGS', true);
    

    You can get rid of this bug until I find an elegant way to fix it.

    •  
      CommentAuthoradityamooley
     

    Thanks. This worked.