Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    •  
      CommentAuthorichigo
     
    i was following the booklink tutorial and was not able to fire up the console.

    it gives me "Connection to the database failed. mysqlt://root:******@localhost:8889/appname_dev"

    any ideas what could cause this? the settings i used to setup akelos seem to have worked,
    as akelos was able to create tables for sessions and caches in all 3 databases.

    i also tried 0.0.0.0 and 127.0.0.1 instead of localhost and also added the port number of the mysql
    database to the config file. i searched for possible solutions on the mailinglist and this forum.
    but i could not find someone who had the same problem. i am using the current dev-preview release from the website.

    i am using mamp as local dev environment

    thanks in advance
    • CommentAuthorraslam
     
    i think you should watch the akelos screen cast. it is also mamp based and it will help.
    •  
      CommentAuthorichigo
     
    thank you for your response. i did watch it but i still don't grasp where the problem is.
    i will try to check out the version from svn and start from scratch. maybe i messed something up.
    •  
      CommentAuthorichigo
     

    i figured it out :)

    using your recommendation on the other thread about inserting

    define('AK_ERROR_REPORTING_ON_SCRIPTS', E_ALL);

    i got this error message:

    Can't connect to local MySQL server through socket '/var/mysql/mysql.sock' (2) in /Applications/MAMP/htdocs/vendor/adodb/drivers/adodb-mysql.inc.php on line 349

    then i looked into that file on line 349 and looked at the code. it appeared like code that handles the way to connect to the database depending on the php version. and it looks like the first condition (check if version is greater than 4.3 was not true) which is odd as mamp uses php5.

    then it was almost clear to me. i went to the script files and replaced the shebang line to the MAMP path to php5

    #!/Applications/MAMP/bin/php5/bin/php

    i guess i only ran into this problem because there is also a php version installed in /usr/bin/php which comes with mac os x already iirc.

    • CommentAuthorraslam
     

    you still did better than me. i'm getting the error saying

    call to undefined fuction mysql_connect();