Akelos Framework v1 forum archive. This forum is no longer maintained. To report bugs please visit https://github.com/akelos/akelos/issues
    • CommentAuthorstevel
     
    I'm walking through the Booklink tutorial. Got stuck after scaffolding. Initially I had a 404 error. Managed to resolved that Rewrite problem. But now I get an blank screen when I tried http://localhost/booklink/book or http://localhost/booklink/author.

    In my .htaccess I have RewriteBase /booklink

    In my httpd.conf I have:
    Alias /booklink "/MyServer/akelos/projects/booklink/public"
    <Directory "/MyServer/akelos/projects/booklink/public">
    Options Indexes FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    In config.php I have the line define('AK_URL_REWRITE_ENABLED', true);

    I'm using a Windows XP platform, Apache for Windows, Php 5.2.4

    Just wondering what I might have missed.
    Thanks for the help.
    • CommentAuthorKaste
     

    "/MyServer/akelos/projects/booklink/public"

    is an 'absolute' path?

    Did you see the web-installer interface? I usually check the setup before I add models, controllers...

    • CommentAuthorKaste
     

    try

    config/config.php...
    define('AK_LOG_EVENTS', true);
    

    then look in log/development.log if you get something.

    • CommentAuthorstevel
     
    Kaste,
    Thanks for the pointers. I'll try the event log. Didn't think of that before.
    Right now I'm not on that machine with the problem, so can only try in a couple of days.

    Btw I believe there is an typo error in the Booklink Tutorial. After the scaffold generation, the link http://localhost/booklink/books should be http://localhost/booklink/book (book as singular)
    • CommentAuthorstevel
     
    Tried enabling the event logging as suggested. And took a look at the event log after rendering. There was nothing unusual as far as I can see. The rendering was completed without any error message. The browser screen is still blank.

    Anyway, I created another booklink project afresh and went through the whole process. And this time round everything turn out ok now. Don't know what I did differently the first time, since I started the first tutorial months ago but for some reason did not complete it. Only return to the tutorial recently and encountered the problem.

    Anyway thanks for the help.
    • CommentAuthorasejua
     

    That happened to me when I uploaded my project to a shared webserver, the screen was just blank. Checked the config.php and everything was okay... then I found a (probably quick and dirty) solution.

    I had the akelos directory outside the main application directory (/akelos & /myapplication in my ftp root of webserver) so I tried to copy akelos/lib and akelos/vendor directories inside the main application directory, changed 'AK_FRAMEWORK_DIR' in my application's config/config.php to point to it's own directory and everything worked.

    You can tell akelos to add the framework inside a project using -deps parameter when creating it (this should be the clean solution :))

    ./script/setup -deps -d HOMEDIR/booklink -p /www/htdocs/booklink
    

    Hope I'm not saying nonsense and that it helps :)

    • CommentAuthordtrejogo
     
    I'm getting the same issue, I tried to copy akelos/lib and akelos/vendor directories inside the main application directory, but still getting a blank page.

    Also I tried
    config/config.php...
    define('AK_LOG_EVENTS', true);

    I'm I don't see the develoment.log, I just have a /log/command_line.log and it is empty

    Any Help